Hello Guest

Author Topic: 2D Toolkit 2.1 beta 1  (Read 39165 times)

midasmax

  • 2D Toolkit
  • Newbie
  • *
  • Posts: 31
    • View Profile
Re: 2D Toolkit 2.1 beta 1
« Reply #30 on: July 10, 2013, 04:48:36 pm »
Thanks for the tips! The import worked fine!

Playing around with the new overrides interface in the editor! It appears that there is a difference between using exact resolutions, and using aspect ratios in Game View, and how it interfaces with the Force Resolution checkbox! :)

unikronsoftware

  • Administrator
  • Hero Member
  • *****
  • Posts: 9709
    • View Profile
Re: 2D Toolkit 2.1 beta 1
« Reply #31 on: July 10, 2013, 05:30:27 pm »
Yes there is. Its recommended to set exact resolutions in game window, if you don't want to deal with setting up resolutions again :)

fsadeq

  • 2D Toolkit
  • Sr. Member
  • *
  • Posts: 353
    • View Profile
Re: 2D Toolkit 2.1 beta 1
« Reply #32 on: July 11, 2013, 02:53:31 am »
Weird bug in the tilemap. I'm not sure how to reproduce it, but I am unable to erase some tiles on one of my layers. I can paint a new one on top of it, but when I erase that, the old one is still underneath it. It is strange because when I commit the map, the colliders for the tiles aren't being created, so it's just the mesh that is stuck in there. Any idea what could be causing this? And yes I am 100% trying to erase on the correct layer  :)

EDIT: Ok, weird. For whatever reason it created like 5 duplicate chunks alongside the "normal" one. I manually deleted them, and it's fine now. Still a bit frightening, though..
« Last Edit: July 11, 2013, 03:58:28 am by fsadeq »

MyNameIsDonovan

  • 2D Toolkit
  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: 2D Toolkit 2.1 beta 1
« Reply #33 on: July 11, 2013, 05:56:28 am »
Unikron, it looks like lighting on tilemaps does not work atm.
And i cant use this to fix it: http://unikronsoftware.com/2dtoolkit/forum/index.php/topic,1080.msg5137.html#msg5137

Am I missing something?

profanicus

  • 2D Toolkit
  • Full Member
  • *
  • Posts: 167
    • View Profile
Re: 2D Toolkit 2.1 beta 1
« Reply #34 on: July 11, 2013, 07:26:09 am »
Unikron, it looks like lighting on tilemaps does not work atm.
And i cant use this to fix it: http://unikronsoftware.com/2dtoolkit/forum/index.php/topic,1080.msg5137.html#msg5137

Am I missing something?

Find the tk2dTileMapMeshBuilder.cs file, search for this line:
Code: [Select]
chunk.mesh.RecalculateBounds(); and add this below it:
         
Code: [Select]
chunk.mesh.RecalculateNormals ();

Fausto

  • 2D Toolkit
  • Newbie
  • *
  • Posts: 12
    • View Profile
FPS hit when enabling the TK2DCamera
« Reply #35 on: July 11, 2013, 08:30:28 am »
Hello friends!

That v3 camera is looking quite nice!
I might have found a problem, though. Just imported the beta and noticed a huge fps drop when enabling the tk2d camera.

I created an empty scene, with a single camera and added the tk2dcamera component to it. After hitting play and testing with the tk2dcamera enabled/disabled state, I noticed a huge fps drop when it was enabled (using the absolutely unreliable internal fps counter, but still, something is happening here).

Is it expected? I asked another tk2d user that has Unity Pro and he said that the LateUpdate is taking a lot of time (around 30% in the empty scene).

I recorded the attached gif to demonstrate the behavior.

Nevertheless, loved the new camera and the pixels/meters references. Started using it right away! Already re-commited my sprite sheets to use the right size and everything is working smooth.

Thanks for the update!

unikronsoftware

  • Administrator
  • Hero Member
  • *****
  • Posts: 9709
    • View Profile
Re: 2D Toolkit 2.1 beta 1
« Reply #36 on: July 11, 2013, 09:09:27 am »
@Fausto - Of course there will be an FPS drop as its doing some calculations in there, but from 5000-3000 I would hardly consider that a "performance hit" - its like 0.1ms, and at that resolution is completely unreliable anyway :) It shouldn't really make any noticeable difference to a real game with things going on in it.

unikronsoftware

  • Administrator
  • Hero Member
  • *****
  • Posts: 9709
    • View Profile
Re: 2D Toolkit 2.1 beta 1
« Reply #37 on: July 11, 2013, 09:10:56 am »
Weird bug in the tilemap. I'm not sure how to reproduce it, but I am unable to erase some tiles on one of my layers. I can paint a new one on top of it, but when I erase that, the old one is still underneath it. It is strange because when I commit the map, the colliders for the tiles aren't being created, so it's just the mesh that is stuck in there. Any idea what could be causing this? And yes I am 100% trying to erase on the correct layer  :)

EDIT: Ok, weird. For whatever reason it created like 5 duplicate chunks alongside the "normal" one. I manually deleted them, and it's fine now. Still a bit frightening, though..

I have seen this before, but I thought it was due to some code we were testing - I'll try to reproduce this more reliably, and if you find a way to make it do this reliably let me know so I can fix it.

fsadeq

  • 2D Toolkit
  • Sr. Member
  • *
  • Posts: 353
    • View Profile
Re: 2D Toolkit 2.1 beta 1
« Reply #38 on: July 11, 2013, 03:40:23 pm »
The only thing I can verify is that I was using the "cut" tool both times it happened.

MyNameIsDonovan

  • 2D Toolkit
  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: 2D Toolkit 2.1 beta 1
« Reply #39 on: July 11, 2013, 05:59:26 pm »
Unikron, it looks like lighting on tilemaps does not work atm.
And i cant use this to fix it: http://unikronsoftware.com/2dtoolkit/forum/index.php/topic,1080.msg5137.html#msg5137

Am I missing something?

Find the tk2dTileMapMeshBuilder.cs file, search for this line:
Code: [Select]
chunk.mesh.RecalculateBounds(); and add this below it:
         
Code: [Select]
chunk.mesh.RecalculateNormals ();
Thanks profanicus, you're the best. I'll add it as soon as I get home :D

TekuStudios

  • 2D Toolkit
  • Full Member
  • *
  • Posts: 177
    • View Profile
    • Teku Studios
Re: 2D Toolkit 2.1 beta 1
« Reply #40 on: July 12, 2013, 05:05:04 pm »
We haven't upgraded yet, but we have a question concerning the new tk2dcamera. Is it still only allowed to be set to Ortographic? We work with Unity's Perspective cameras, but your tk2camera has many improvements that could come in handy.
We are an Indie videogame developer located in Teruel, Spain. A small 6-people team which is currently working on the upcoming 'Candle'.

fsadeq

  • 2D Toolkit
  • Sr. Member
  • *
  • Posts: 353
    • View Profile
Re: 2D Toolkit 2.1 beta 1
« Reply #41 on: July 12, 2013, 09:54:28 pm »
We haven't upgraded yet, but we have a question concerning the new tk2dcamera. Is it still only allowed to be set to Ortographic? We work with Unity's Perspective cameras, but your tk2camera has many improvements that could come in handy.

You can choose between ortho or perspective. Go ahead and upgrade and give it a shot.

fsadeq

  • 2D Toolkit
  • Sr. Member
  • *
  • Posts: 353
    • View Profile
Re: 2D Toolkit 2.1 beta 1
« Reply #42 on: July 13, 2013, 04:51:26 am »
Weird bug in the tilemap. I'm not sure how to reproduce it, but I am unable to erase some tiles on one of my layers. I can paint a new one on top of it, but when I erase that, the old one is still underneath it. It is strange because when I commit the map, the colliders for the tiles aren't being created, so it's just the mesh that is stuck in there. Any idea what could be causing this? And yes I am 100% trying to erase on the correct layer  :)

EDIT: Ok, weird. For whatever reason it created like 5 duplicate chunks alongside the "normal" one. I manually deleted them, and it's fine now. Still a bit frightening, though..

I have seen this before, but I thought it was due to some code we were testing - I'll try to reproduce this more reliably, and if you find a way to make it do this reliably let me know so I can fix it.

Just happened to me again - not sure how to replicate. This time there were no duplicate chunks though - they were just stuck and I couldn't erase. Had to manually delete the chunk from the Render Data after committing.

unikronsoftware

  • Administrator
  • Hero Member
  • *****
  • Posts: 9709
    • View Profile
Re: 2D Toolkit 2.1 beta 1
« Reply #43 on: July 13, 2013, 03:11:15 pm »
I worked out the situations that can trigger this. It boils down to undo handling and the variety of random things that can happen as a result. I should have it fixed in the next release.

kwhittington

  • 2D Toolkit
  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: 2D Toolkit 2.1 beta 1
« Reply #44 on: July 13, 2013, 11:06:21 pm »
Hi I'm having an issue with tiles maps now that I've upgraded to the beta.
The TileMap tiles lost their collider data, you can still set it in the editor (e.g Box Trimmed) but it doesn't seem to be created at run time (the character is falling through the tiles).

Could this be related to the Attach Points being added and not having set them up on the tiles?

Thanks.