Hello Guest

Author Topic: 2D Toolkit 1.75 final  (Read 10722 times)

unikronsoftware

  • Administrator
  • Hero Member
  • *****
  • Posts: 9709
    • View Profile
2D Toolkit 1.75 final
« on: June 24, 2012, 09:58:30 pm »
1.75 final

A few more bugfixes
BUGFIX: Poly collider editor fixed
BUGFIX: CreateCollider reverts to UpdateCollider when the game is running in editor
BUGFIX: A few more usability fixes
BUGFIX: AnimatedSprite.StopAndResetFrame() stops the currently playing animation and resets to frame 0
BUGFIX: Thumbnail not displayed when sprite collection is missing
BUGFIX: Sprite collection data object inherits the name of the editor object, instead of defaulting to "data"


EDIT: Fixed incorrect upload
« Last Edit: June 25, 2012, 02:24:10 am by unikron »

fsadeq

  • 2D Toolkit
  • Sr. Member
  • *
  • Posts: 353
    • View Profile
Re: 2D Toolkit 1.75 final
« Reply #1 on: June 24, 2012, 11:11:42 pm »
Thanks for the update. Though I upgraded and now I get this error:

Code: [Select]
Assets/TK2DROOT/tk2d/Editor/Tilemap/Importer/tk2dTileMapImporter.cs(126,79): error CS0117: `tk2dEditor.TileMap.TileMapUtility' does not contain a definition for `FindOrCreateLayer'

unikronsoftware

  • Administrator
  • Hero Member
  • *****
  • Posts: 9709
    • View Profile
Re: 2D Toolkit 1.75 final
« Reply #2 on: June 24, 2012, 11:28:34 pm »
Hey,

I just tested importing this into a blank project and I don't get these errors. Perhaps one of the files didn't import correctly? Is there another error before this which stopped some of the scripts from importing? tk2dTileMapUtility.cs does indeed have this function in the version posted here.

fsadeq

  • 2D Toolkit
  • Sr. Member
  • *
  • Posts: 353
    • View Profile
Re: 2D Toolkit 1.75 final
« Reply #3 on: June 25, 2012, 01:43:54 am »
No, there were no other errors prior. I had to just delete the whole thing and import it and it doesn't have the error anymore. Question though, should it not say 1.75 Final when I read the 'about' under the 2DTK menu? Mine says 1.7 Final, as does the file name of the package you posted.

unikronsoftware

  • Administrator
  • Hero Member
  • *****
  • Posts: 9709
    • View Profile
Re: 2D Toolkit 1.75 final
« Reply #4 on: June 25, 2012, 02:24:57 am »
Sorry, looks like I accidentally uploaded the wrong version. I had all the previous releases in the same directory, and uploaded 1.7 instead of 1.75 :(

fsadeq

  • 2D Toolkit
  • Sr. Member
  • *
  • Posts: 353
    • View Profile
Re: 2D Toolkit 1.75 final
« Reply #5 on: June 25, 2012, 04:04:33 am »
All good now, thanks!

theremin

  • 2D Toolkit
  • Newbie
  • *
  • Posts: 20
    • View Profile
Re: 2D Toolkit 1.75 final
« Reply #6 on: June 25, 2012, 08:04:04 pm »
Is the animation Wrap Mode "Loop Section" functionality broken in this release? I just started using Loop Section for the first time this morning -- so this could be my fault -- but I could have sworn this working right before I upgraded from 1.7 to 1.75.

I have a 9-frame animation, with Wrap Mode set to "Loop Section" and Loop Start set to 1. The animation plays frames 0-8 correctly, but as soon as it's supposed to reset to frame 1, I start getting a barrage of errors on this line:

Code: [Select]
IndexOutOfRangeException: Array index is out of range.
tk2dAnimatedSprite.SetFrameInternal (Int32 currFrame) (at Assets/TK2DROOT/tk2d/Code/Sprites/tk2dAnimatedSprite.cs:351)
tk2dAnimatedSprite.Update () (at Assets/TK2DROOT/tk2d/Code/Sprites/tk2dAnimatedSprite.cs:406)

Looks like "currFrame" (passed into SetFrameInternal) just keeps on going -- frame 9, frame 10, frame 11, etc.

Am I doing something wrong, or is this broken in 2D Toolkit?

unikronsoftware

  • Administrator
  • Hero Member
  • *****
  • Posts: 9709
    • View Profile
Re: 2D Toolkit 1.75 final
« Reply #7 on: June 25, 2012, 10:50:19 pm »
That is a bug, the line should read
Code: [Select]
SetFrameInternal(currFrameLooped);

Sorry about that.

Bona

  • 2D Toolkit
  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: 2D Toolkit 1.75 final
« Reply #8 on: June 26, 2012, 02:10:31 pm »
Thank you for the update, I noticed that when I use PlayFromFrame( xx ) to jump and play within Update( ), frame 0 of the clip always appear for a split second, but when I use the same function in FixedUpdate ( ) it won't happen.

Should I always use PlayFromFrame within FixedUpdate( ) or there's a way to avoid frame 0 flash out before each jump in Update( )?

unikronsoftware

  • Administrator
  • Hero Member
  • *****
  • Posts: 9709
    • View Profile
Re: 2D Toolkit 1.75 final
« Reply #9 on: June 26, 2012, 08:47:08 pm »
No, it looks like that might be a bug. Calling it from FixedUpdate isn't guaranteed to work if FixedUpdate runs at the same frequency as Update. Could you get in touch by email - I have a potential fix for this, but its too big to paste here.

Bona

  • 2D Toolkit
  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: 2D Toolkit 1.75 final
« Reply #10 on: June 27, 2012, 07:44:19 am »
Oh yes please, have pm u my address.
Your support is great!  Thank you ;D

unikronsoftware

  • Administrator
  • Hero Member
  • *****
  • Posts: 9709
    • View Profile
Re: 2D Toolkit 1.75 final
« Reply #11 on: July 02, 2012, 11:38:06 pm »
There are a few issues which have been resolved. A new patch will be released this week.

- Animation frames flickering when first started
- Loopsection bug fix
- More animation bugfixes
- Prefab instances weren't being updated when the master is updated

fsadeq

  • 2D Toolkit
  • Sr. Member
  • *
  • Posts: 353
    • View Profile
Re: 2D Toolkit 1.75 final
« Reply #12 on: July 03, 2012, 04:09:58 pm »
Thanks! I thought I was going crazy with the animation flickering when first starting! Thought my transform was flipping on the z axis or something strange.