Hello Guest

Author Topic: Disappearing parts of tilemap in editor  (Read 3292 times)

andrew2110

  • 2D Toolkit
  • Newbie
  • *
  • Posts: 6
    • View Profile
Disappearing parts of tilemap in editor
« on: October 14, 2014, 02:42:06 pm »
Hello all,

I'm having some problems with t2kdtilemap. When editing maps it would appear that occasionally whole segments of tiles will just disappear for no reason as shown in this video:

http://www.blueomega.me/Output.mp4

The first disappearance of tiles is from just normal map editing, the second is when I click Edit -> Undo.

Does anyone know what could be the cause of this?

blueomegajon

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Disappearing parts of tilemap in editor
« Reply #1 on: October 14, 2014, 05:01:14 pm »
Just to add onto the top post (we're working together on this project).

https://www.youtube.com/watch?v=t9G64aVaLzM&feature=youtube_gdata_player This video shows the issue on another map. On trying to place a single tile every* other tile on the same layer in a 32x32 area disappears.

https://www.youtube.com/watch?v=W-IOHJB2Sro&feature=youtube_gdata_player *This second video shows that the only tiles that disappear are the same ones that disappear on 'commit'.

unikronsoftware

  • Administrator
  • Hero Member
  • *****
  • Posts: 9709
    • View Profile
Re: Disappearing parts of tilemap in editor
« Reply #2 on: October 15, 2014, 10:55:19 pm »
I am not sure why this is happening. Can you create a repro case please?

jmenossi

  • 2D Toolkit
  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: Disappearing parts of tilemap in editor
« Reply #3 on: October 16, 2014, 11:55:14 am »
I had similar issue. It happened only on some tiles with Prefabs.
In the scene window, I only could see the tiles when editing, but once commited tiles dissapeared. When playing, prefab objects were right.

The only way I found to fix my tilemap:
-Edit the tilemap and delete those tiles, then commit.
-Edit again, re-add tiles and commit.

Now I see the map correctly on scene window, but I have seen this issue twice already....

unikronsoftware

  • Administrator
  • Hero Member
  • *****
  • Posts: 9709
    • View Profile
Re: Disappearing parts of tilemap in editor
« Reply #4 on: October 16, 2014, 12:13:57 pm »
Ooh regarding prefabs, your scene view was probably set to perspective and you were rotated slightlly? In game it would be ortho and would be sorted correctly... Try "2D" mode or orthographic to see if it works properly for you.

jmenossi

  • 2D Toolkit
  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: Disappearing parts of tilemap in editor
« Reply #5 on: October 16, 2014, 06:51:22 pm »
Well, it is a 2D project and the scene window is in 2D mode, so I think this may not be the cause.
And this happened only with SOME tiles with prefabs, not all of them.
I will try to send a sample project if I face this again.
« Last Edit: October 16, 2014, 06:57:49 pm by jmenossi »

blueomegajon

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Disappearing parts of tilemap in editor
« Reply #6 on: October 17, 2014, 12:52:30 pm »
It might be a bit difficult to make a repro as I can't make it happen with any consistency. It seems to happen more often when I try and drag and drop quite a large area of tiles.

I'm managing it by committing and applying fairly regularly.